summaryrefslogtreecommitdiff
path: root/alsaucm/Makefile.am
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@slimlogic.co.uk>2009-09-30 21:12:17 +0200
committerLiam Girdwood <lrg@slimlogic.co.uk>2010-08-22 22:04:00 +0100
commita9d91614bb310b5f5c05e193ef7559bc512af72e (patch)
tree06b6364f9c9a726cbca9ea5b4e52815ff77707f0 /alsaucm/Makefile.am
parentbb865dc10b6dcee9d428d3c5a17ee312e0aaf7e0 (diff)
downloadalsa-utils-a9d91614bb310b5f5c05e193ef7559bc512af72e.tar.gz
alsaucm: Add Use Case Manager utility
alsaucm is a command line tool that can be used to generate and debug UCM configuration files. The alsaucm utility can fully use the UCM functionality to query and configure all the UCM functionality in alsa-lib. This work was sponsored by Slimlogic Ltd, Texas Instruments Inc and Wolfson Microelectronics PLC. CC: Ian Molton <ian@mnementh.co.uk> CC: Graeme Gregory <gg@slimlogic.co.uk> Signed-off-by: Justin Xu <justinx@slimlogic.co.uk> Signed-off-by: Stefan Schmidt <stefan@slimlogic.co.uk> Signed-off-by: Liam Girdwood <lrg@slimlogic.co.uk>
Diffstat (limited to 'alsaucm/Makefile.am')
-rw-r--r--alsaucm/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/alsaucm/Makefile.am b/alsaucm/Makefile.am
new file mode 100644
index 0000000..50e1f5b
--- /dev/null
+++ b/alsaucm/Makefile.am
@@ -0,0 +1,9 @@
+bin_PROGRAMS = \
+ alsaucm
+
+alsaucm_SOURCES = usecase.c
+
+INCLUDES = \
+ -Wall -I$(top_srcdir)/include
+
+alsaucm_LDADD = -lasound