summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLu, Han <han.lu@intel.com>2015-09-23 15:48:55 +0800
committerTakashi Iwai <tiwai@suse.de>2015-10-02 12:42:03 +0200
commit226ad884d22a482ba4d10d12db2ed6518ed60e1b (patch)
treeed2b9fa08d1e2af11054755bfe657cbff53651f0 /configure.ac
parentd727c9d90e4150e5108dbae73c64ef7a5db8e411 (diff)
downloadalsa-utils-226ad884d22a482ba4d10d12db2ed6518ed60e1b.tar.gz
BAT: Add Makefile and configures
Add Makefile and configures that enable BAT on alsa-utils Signed-off-by: Lu, Han <han.lu@intel.com> Signed-off-by: Liam Girdwood <liam.r.girdwood@intel.com> Signed-off-by: Bernard Gautier <bernard.gautier@intel.com> Signed-off-by: Takashi Iwai <tiwai@suse.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4c279a9..8c2d1a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,23 @@ AM_CONDITIONAL(HAVE_UCM, test "$have_ucm" = "yes")
AM_CONDITIONAL(HAVE_TOPOLOGY, test "$have_topology" = "yes")
AM_CONDITIONAL(HAVE_SAMPLERATE, test "$have_samplerate" = "yes")
+AC_CHECK_LIB([fftw3], [fftw_malloc], , [AC_MSG_ERROR([Error: need FFTW3 library])])
+AC_CHECK_LIB([m], [sqrtf], , [AC_MSG_ERROR([Error: Need sqrtf])])
+AC_CHECK_LIB([pthread], [pthread_create], , [AC_MSG_ERROR([Error: need PTHREAD library])])
+
+dnl Disable bat
+bat=
+if test "$have_pcm" = "yes"; then
+AC_ARG_ENABLE(bat,
+ AS_HELP_STRING([--disable-bat], [Disable bat compilation]),
+ [case "${enableval}" in
+ yes) bat=true ;;
+ no) bat=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-bat) ;;
+ esac],[bat=true])
+fi
+AM_CONDITIONAL(BAT, test x$bat = xtrue)
+
dnl Check for librt
LIBRT=""
AC_MSG_CHECKING(for librt)
@@ -361,7 +378,7 @@ AC_OUTPUT(Makefile alsactl/Makefile alsactl/init/Makefile \
m4/Makefile po/Makefile.in \
alsaconf/alsaconf alsaconf/Makefile \
alsaconf/po/Makefile \
- alsaucm/Makefile topology/Makefile \
+ alsaucm/Makefile topology/Makefile bat/Makefile \
aplay/Makefile include/Makefile iecset/Makefile utils/Makefile \
utils/alsa-utils.spec seq/Makefile seq/aconnect/Makefile \
seq/aplaymidi/Makefile seq/aseqdump/Makefile seq/aseqnet/Makefile \