summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAntonio Ospite <ao2@ao2.it>2016-12-09 14:02:30 +0100
committerTakashi Iwai <tiwai@suse.de>2016-12-09 17:22:11 +0100
commit59e32319df47d4f1a5c08dba1bb9b3c412d9eb1d (patch)
treee060944b0bb3d9a8c169506b23195bf1de9bc75a /configure.ac
parentb235b50129b6195e502a5b25841a13d725a4766b (diff)
downloadalsa-utils-59e32319df47d4f1a5c08dba1bb9b3c412d9eb1d.tar.gz
configure.ac: add a check for rst2man, a reStructuredText man page generator
Define a USE_RST2MAN conditional so that, when available, rst2man can be used to generate man pages from reStructuredText source files. The code follows what is done to check for xmlto. On Debian system, the rst2man executable is provided by python-docutils or python3-docutils. Signed-off-by: Antonio Ospite <ao2@ao2.it> Signed-off-by: Takashi Iwai <tiwai@suse.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9629bb..d8fcf0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,6 +175,15 @@ if test "$xmlto" = "yes"; then
fi
AM_CONDITIONAL(USE_XMLTO, test x"$xmlto_available" = xyes)
+rst2man_available=""
+AC_ARG_ENABLE(rst2man,
+ AS_HELP_STRING([--disable-rst2man], [Disable man page creation via rst2man]),
+ rst2man="$enableval", rst2man="yes")
+if test "$rst2man" = "yes"; then
+ AC_CHECK_PROG([rst2man_available], [rst2man], [yes])
+fi
+AM_CONDITIONAL(USE_RST2MAN, test x"$rst2man_available" = xyes)
+
AC_ARG_WITH(
[udev-rules-dir],
AS_HELP_STRING([--with-udev-rules-dir=DIR],[Directory where to install udev rules to (default=auto)]),