summaryrefslogtreecommitdiff
path: root/topology/Makefile.am
diff options
context:
space:
mode:
authorRanjani Sridharan <ranjani.sridharan@linux.intel.com>2021-04-26 13:26:08 -0700
committerJaroslav Kysela <perex@perex.cz>2021-05-25 18:26:51 +0200
commit4bc386bb715ea303dfffe46d1da4d242ca1d3914 (patch)
treee2d3563bcf04b8909b08a6ffaab37fbbf78bd8a2 /topology/Makefile.am
parentb0be2350244bd427aef448bf79336ee0f70648e0 (diff)
downloadalsa-utils-4bc386bb715ea303dfffe46d1da4d242ca1d3914.tar.gz
topology: pre-process-dai: add support for hwcfg objects
Add supprt for hwcfg objects: For ex: Object.Base.hw_config."SSP0 hw_config 0" { id 0 mclk_freq 24000000 bclk_freq 4800000 tdm_slot_width 25 } would get converted to: SectionHWConfig { 'SSP0 hw_config 0' { id 0 format I2S bclk codec_consumer bclk_freq 4800000 fsync codec_consumer fsync_freq 48000 mclk codec_mclk_in mclk_freq 24000000 tdm_slots 2 tdm_slot_width 25 tx_slots 3 rx_slots 3 } } and the corresponding SectionBE will be updated with the hwcfgs reference as: hw_configs [ 'SSP0 hw_config 0' ] Signed-off-by: Ranjani Sridharan <ranjani.sridharan@linux.intel.com> Signed-off-by: Jaroslav Kysela <perex@perex.cz>
Diffstat (limited to 'topology/Makefile.am')
-rw-r--r--topology/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/topology/Makefile.am b/topology/Makefile.am
index 7c9392c..7f77fdd 100644
--- a/topology/Makefile.am
+++ b/topology/Makefile.am
@@ -9,7 +9,7 @@ endif
rst2man $< > $@
alsatplg_SOURCES = topology.c pre-processor.c pre-process-class.c pre-process-object.c \
- pre-process-dapm.c
+ pre-process-dapm.c pre-process-dai.c
noinst_HEADERS = topology.h pre-processor.h