summaryrefslogtreecommitdiff
path: root/topology/Makefile.am
diff options
context:
space:
mode:
authorRanjani Sridharan <ranjani.sridharan@linux.intel.com>2021-04-26 12:49:51 -0700
committerJaroslav Kysela <perex@perex.cz>2021-05-25 18:26:51 +0200
commit96b5e5a87536f57566fd59d89789a243f82e890e (patch)
treee3c95539fb966f9929b4f1289515b7a1fc8680a0 /topology/Makefile.am
parent032d1250c7225ec2723f598b1d61d37dba0527ee (diff)
downloadalsa-utils-96b5e5a87536f57566fd59d89789a243f82e890e.tar.gz
topology: pre-process-dapm: Add support for tlv objects
Add support for pre-processing TLV objects For example: Object.Base.tlv."vtlv_m64s2" {} will be converted to: SectionTLV.'vtlv_m64s2' {} And the mixer controle section will be updated to add the reference to the tlv object. Signed-off-by: Ranjani Sridharan <ranjani.sridharan@linux.intel.com> Signed-off-by: Jaroslav Kysela <perex@perex.cz>
Diffstat (limited to 'topology/Makefile.am')
-rw-r--r--topology/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/topology/Makefile.am b/topology/Makefile.am
index 8efbf4f..7c9392c 100644
--- a/topology/Makefile.am
+++ b/topology/Makefile.am
@@ -8,7 +8,8 @@ endif
%.1: %.rst
rst2man $< > $@
-alsatplg_SOURCES = topology.c pre-processor.c pre-process-class.c pre-process-object.c
+alsatplg_SOURCES = topology.c pre-processor.c pre-process-class.c pre-process-object.c \
+ pre-process-dapm.c
noinst_HEADERS = topology.h pre-processor.h