summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Martz <matt@sivel.net>2021-09-21 13:43:31 -0500
committerGitHub <noreply@github.com>2021-09-21 13:43:31 -0500
commit724800cd3f39867943adb198bcbb8ab2523809c1 (patch)
tree90322b9e3279756c0b31e3843692418c306fe476 /setup.py
parent4ab90f3afcc0f118bfbf1a58c8eb0fc646c4ea72 (diff)
downloadansible-724800cd3f39867943adb198bcbb8ab2523809c1.tar.gz
Python 3.8 Controller Minimum (#74013)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 2 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 1cf9f08ff1..11f88c6afa 100644
--- a/setup.py
+++ b/setup.py
@@ -333,7 +333,7 @@ static_setup_params = dict(
license='GPLv3+',
# Ansible will also make use of a system copy of python-six and
# python-selectors2 if installed but use a Bundled copy if it's not.
- python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*',
+ python_requires='>=3.8',
package_dir={'': 'lib',
'ansible_test': 'test/lib/ansible_test'},
packages=find_packages('lib') + find_packages('test/lib'),
@@ -347,14 +347,10 @@ static_setup_params = dict(
'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
'Natural Language :: English',
'Operating System :: POSIX',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Topic :: System :: Installation/Setup',
'Topic :: System :: Systems Administration',
'Topic :: Utilities',