summaryrefslogtreecommitdiff
path: root/packaging/debian
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/debian')
-rw-r--r--packaging/debian/Dockerfile20
-rw-r--r--packaging/debian/README.md39
-rw-r--r--packaging/debian/ansible-core.dirs4
-rw-r--r--packaging/debian/ansible-core.install15
-rw-r--r--packaging/debian/ansible-test.install2
-rw-r--r--packaging/debian/changelog5
-rw-r--r--packaging/debian/compat1
-rw-r--r--packaging/debian/control29
-rw-r--r--packaging/debian/copyright26
-rw-r--r--packaging/debian/docs1
-rw-r--r--packaging/debian/pycompat1
-rwxr-xr-xpackaging/debian/rules9
12 files changed, 0 insertions, 152 deletions
diff --git a/packaging/debian/Dockerfile b/packaging/debian/Dockerfile
deleted file mode 100644
index de831d09cf..0000000000
--- a/packaging/debian/Dockerfile
+++ /dev/null
@@ -1,20 +0,0 @@
-FROM ubuntu:xenial
-
-RUN apt-get update && apt-get install -y \
- python-docutils \
- cdbs \
- debootstrap \
- devscripts \
- make \
- pbuilder \
- python-jinja2 \
- python-setuptools \
- python-yaml \
- && \
- apt-get clean
-
-VOLUME /ansible
-WORKDIR /ansible
-
-ENTRYPOINT ["/bin/bash", "-c"]
-CMD ["make deb"]
diff --git a/packaging/debian/README.md b/packaging/debian/README.md
deleted file mode 100644
index 7eaa472139..0000000000
--- a/packaging/debian/README.md
+++ /dev/null
@@ -1,39 +0,0 @@
-Ansible Debian Package
-======================
-
-To create an Ansible DEB package:
-
-__Note__: You must run this target as root or set `PBUILDER_BIN='sudo pbuilder'`
-
-```
-apt-get install python-docutils cdbs debootstrap devscripts make pbuilder python-setuptools
-git clone https://github.com/ansible/ansible.git
-cd ansible
-DEB_DIST='xenial trusty precise' make deb
-```
-
-Building in Docker:
-
-```
-git clone https://github.com/ansible/ansible.git
-cd ansible
-docker build -t ansible-deb-builder -f packaging/debian/Dockerfile .
-docker run --privileged -e DEB_DIST='trusty' -v $(pwd):/ansible ansible-deb-builder
-```
-
-The debian package file will be placed in the `deb-build` directory. This can then be added to an APT repository or installed with `dpkg -i <package-file>`.
-
-Note that `dpkg -i` does not resolve dependencies.
-
-To install the Ansible DEB package and resolve dependencies:
-
-```
-dpkg -i <package-file>
-apt-get -fy install
-```
-
-Or, if you are running Debian Stretch (or later) or Ubuntu Xenial (or later):
-
-```
-apt install /path/to/<package-file>
-```
diff --git a/packaging/debian/ansible-core.dirs b/packaging/debian/ansible-core.dirs
deleted file mode 100644
index fba15a432f..0000000000
--- a/packaging/debian/ansible-core.dirs
+++ /dev/null
@@ -1,4 +0,0 @@
-etc/ansible
-etc/ansible/roles
-usr/lib/python3/dist-packages/ansible
-usr/share/ansible
diff --git a/packaging/debian/ansible-core.install b/packaging/debian/ansible-core.install
deleted file mode 100644
index d2dac7c1a5..0000000000
--- a/packaging/debian/ansible-core.install
+++ /dev/null
@@ -1,15 +0,0 @@
-examples/hosts etc/ansible
-docs/man/man1/*.1 usr/share/man/man1
-debian/tmp/usr/bin/ansible-galaxy usr/bin
-debian/tmp/usr/bin/ansible-vault usr/bin
-debian/tmp/usr/bin/ansible-doc usr/bin
-debian/tmp/usr/bin/ansible-console usr/bin
-debian/tmp/usr/bin/ansible-connection usr/bin
-debian/tmp/usr/bin/ansible-inventory usr/bin
-debian/tmp/usr/bin/ansible-config usr/bin
-debian/tmp/usr/bin/ansible-pull usr/bin
-debian/tmp/usr/bin/ansible-playbook usr/bin
-debian/tmp/usr/bin/ansible usr/bin
-examples/ansible.cfg etc/ansible
-debian/tmp/usr/lib/python3/dist-packages/ansible usr/lib/python3/dist-packages
-debian/tmp/usr/lib/python3/dist-packages/ansible_*.egg-info
diff --git a/packaging/debian/ansible-test.install b/packaging/debian/ansible-test.install
deleted file mode 100644
index 9252890580..0000000000
--- a/packaging/debian/ansible-test.install
+++ /dev/null
@@ -1,2 +0,0 @@
-debian/tmp/usr/bin/ansible-test usr/bin
-debian/tmp/usr/lib/python3/dist-packages/ansible_test usr/lib/python3/dist-packages
diff --git a/packaging/debian/changelog b/packaging/debian/changelog
deleted file mode 100644
index 799f390eee..0000000000
--- a/packaging/debian/changelog
+++ /dev/null
@@ -1,5 +0,0 @@
-ansible-core (%VERSION%-%RELEASE%~%DIST%) %DIST%; urgency=low
-
- * %VERSION% release
-
- -- Ansible, Inc. <info@ansible.com> %DATE%
diff --git a/packaging/debian/compat b/packaging/debian/compat
deleted file mode 100644
index 7ed6ff82de..0000000000
--- a/packaging/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/packaging/debian/control b/packaging/debian/control
deleted file mode 100644
index ba72468847..0000000000
--- a/packaging/debian/control
+++ /dev/null
@@ -1,29 +0,0 @@
-Source: ansible-core
-Section: admin
-Priority: optional
-Standards-Version: 3.9.3
-Maintainer: Ansible, Inc. <info@ansible.com>
-Build-Depends: cdbs, debhelper (>= 5.0.0), python3-docutils, python3, dh-python | python-support, python3-setuptools, lsb-release, python3-straight.plugin, python3-packaging, python3-jinja2
-Homepage: https://github.com/ansible/ansible/
-
-Package: ansible-core
-Architecture: all
-Depends: python3-jinja2, python3-yaml, python3-paramiko, python3-cryptography, sshpass, ${misc:Depends}, ${python:Depends}
-Description: Ansible IT Automation
- Ansible is a radically simple model-driven configuration management,
- multi-node deployment, and remote task execution system. Ansible works
- over SSH and does not require any software or daemons to be installed
- on remote nodes. Extension modules can be written in any language and
- are transferred to managed machines automatically.
-
-Package: ansible-test
-Architecture: all
-Depends: ansible-core (= ${binary:Version}), python3-venv, ${misc:Depends}
-Description: Ansible IT Automation
- Ansible is a radically simple model-driven configuration management,
- multi-node deployment, and remote task execution system. Ansible works
- over SSH and does not require any software or daemons to be installed
- on remote nodes. Extension modules can be written in any language and
- are transferred to managed machines automatically.
- This package installs the ansible-test command for testing modules and
- plugins developed for ansible.
diff --git a/packaging/debian/copyright b/packaging/debian/copyright
deleted file mode 100644
index 4a17425fbb..0000000000
--- a/packaging/debian/copyright
+++ /dev/null
@@ -1,26 +0,0 @@
-This package was debianized by Henry Graham (hzgraham) <Henry.Graham@mail.wvu.edu> on
-Tue, 17 Apr 2012 12:19:47 -0400.
-
-It was downloaded from https://github.com/ansible/ansible.git
-
-Copyright: Henry Graham (hzgraham) <Henry.Graham@mail.wvu.edu>
-
-License:
-
- This package is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; version 2 dated June, 1991.
-
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this package; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301,
- USA.
-
-On Debian systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
-
diff --git a/packaging/debian/docs b/packaging/debian/docs
deleted file mode 100644
index a1320b1b4a..0000000000
--- a/packaging/debian/docs
+++ /dev/null
@@ -1 +0,0 @@
-README.rst
diff --git a/packaging/debian/pycompat b/packaging/debian/pycompat
deleted file mode 100644
index 0cfbf08886..0000000000
--- a/packaging/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/packaging/debian/rules b/packaging/debian/rules
deleted file mode 100755
index 2c0231c637..0000000000
--- a/packaging/debian/rules
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/usr/bin/make -f
-# -- makefile --
-
-DEB_PYTHON3_MODULE_PACKAGES=ansible-core ansible_test
-#DEB_PYTHON_INSTALL_ARGS_ALL="--install-purelib=/usr/lib/python2.7/site-packages/"
-DEB_PYTHON_DISTUTILS_INSTALLDIR_SKEL = /usr/lib/python3/dist-packages/
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/python-distutils.mk