summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Zhakov <ivan@apache.org>2019-10-15 10:59:58 +0000
committerIvan Zhakov <ivan@apache.org>2019-10-15 10:59:58 +0000
commit51b539596a9676ccc9b392b5b35c7a60174b1844 (patch)
tree0e941ca85ba6e9986fffdc8a51daec6d1e5e1eac /CMakeLists.txt
parentcd40cc64f1d526f6c1659dd5777a36fd58031597 (diff)
downloadapr-51b539596a9676ccc9b392b5b35c7a60174b1844.tar.gz
apr_proc_create(): Properly escape arguments containing whitespace characters
on Windows. * CMakeLists.txt (single_source_programs): Add test/echoargs.c. * test/echoargs.c: New test app for test_proc_args test. * test/testproc.c (test_proc_args): New test. (testproc): Add test_proc_args to test list. * threadproc/win32/proc.c (quote_arg): New. Helper for apr_proc_create(). (apr_proc_create): Use quote_arg() helper to escape arguments in command line. git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1868477 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c731fc816..e42fd6d8d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -560,6 +560,7 @@ IF(APR_BUILD_TESTAPR)
# requirements.
SET(single_source_programs
test/dbd.c
+ test/echoargs.c
test/echod.c
test/sendfile.c
test/sockperf.c