summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeff Trawick <trawick@apache.org>2013-08-23 14:45:26 +0000
committerJeff Trawick <trawick@apache.org>2013-08-23 14:45:26 +0000
commit7024b5491b60dcd15091cb6db5086321f092aad1 (patch)
treef52ebffd7906b5880458082d1b1693156707a91e /CMakeLists.txt
parentc104595f7a42ce0d1ea9013f5bf51e6a24051ef5 (diff)
downloadapr-7024b5491b60dcd15091cb6db5086321f092aad1.tar.gz
tiny cleanup to how feature test values for apr.h are initialized
git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1516871 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 11 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57bd4efdb..6308d6048 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,23 +54,26 @@ OPTION(APR_HAVE_IPV6 "IPv6 support" ON)
OPTION(APR_SHOW_SETTINGS "Show the build configuration" ON)
OPTION(APR_BUILD_TESTAPR "Build the test suite" OFF)
-IF(APR_HAVE_IPV6)
- SET(apr_have_ipv6_10 1)
-ELSE()
- SET(apr_have_ipv6_10 0)
-ENDIF()
-
IF(NOT APU_USE_EXPAT AND NOT APU_USE_LIBXML2)
MESSAGE(FATAL_ERROR "Either Expat or LibXml2 must be selected")
ENDIF()
IF(APU_USE_EXPAT AND APU_USE_LIBXML2)
MESSAGE(FATAL_ERROR "Only one of Expat and LibXml2 can be selected")
ENDIF()
+
+# create 1-or-0 representation of feature tests for apr.h
+
+SET(apr_have_ipv6_10 0)
+SET(apu_use_libxml2_10 0)
+SET(apu_use_expat_10 0)
+
+IF(APR_HAVE_IPV6)
+ SET(apr_have_ipv6_10 1)
+ENDIF()
+
IF(APU_USE_EXPAT)
SET(apu_use_expat_10 1)
- SET(apu_use_libxml2_10 0)
ELSE()
- SET(apu_use_expat_10 0)
SET(apu_use_libxml2_10 1)
ENDIF()