summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWilliam A. Rowe Jr <wrowe@apache.org>2022-05-24 14:14:13 +0000
committerWilliam A. Rowe Jr <wrowe@apache.org>2022-05-24 14:14:13 +0000
commit8e66e54e9e0c1c54c8eaea74f2aeec810a5c8494 (patch)
treec97fb9cc8741d494ead5d2936324aaee2c6d3814 /CMakeLists.txt
parentb5c1cd20295430a4f10904899b38732729ae6af7 (diff)
downloadapr-8e66e54e9e0c1c54c8eaea74f2aeec810a5c8494.tar.gz
Followup to r1901212; Normalize ucs-4 to utf-32
git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1901213 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index adee368af..f1c913130 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,7 +64,7 @@ OPTION(APU_HAVE_CRYPTO "Crypto support" OFF)
OPTION(APU_HAVE_ICONV "Xlate support" OFF)
OPTION(APR_HAVE_IPV6 "IPv6 support" ON)
OPTION(INSTALL_PDB "Install .pdb files (if generated)" ON)
-OPTION(APR_BUILD_TESTAPR "Build the test suite" OFF)
+OPTION(APR_BUILD_TESTAPR "Build the test suite" ON)
OPTION(TEST_STATIC_LIBS "Test programs use APR static libraries instead of shared libraries?" OFF)
IF(NOT APU_USE_EXPAT AND NOT APU_USE_LIBXML2 AND NOT APU_USE_XMLLITE)
@@ -617,7 +617,7 @@ IF(APR_BUILD_TESTAPR)
test/testshmproducer.c
test/testshmconsumer.c
test/tryread.c
- test/internal/testucs.c
+ test/internal/testutf.c
)
FOREACH(sourcefile ${single_source_programs})
@@ -632,7 +632,7 @@ IF(APR_BUILD_TESTAPR)
# Add tests for programs that run by themselves with no arguments.
SET(simple_tests
testmutexscope
- testucs
+ testutf
)
FOREACH(simple ${simple_tests})