summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Zhakov <ivan@apache.org>2019-05-20 15:06:28 +0000
committerIvan Zhakov <ivan@apache.org>2019-05-20 15:06:28 +0000
commitc2fbd97b2f2d5a5ab838e4271bdb8d28fea97aaa (patch)
tree4c1f16dc325546719defc9c2e94c0a799df7bd23 /CMakeLists.txt
parentfe839d9c70442018ca29d6d21a3d85cf71bcbfd6 (diff)
parent9ef9d1331dbf386604e89bac81505ad0116467ff (diff)
downloadapr-c2fbd97b2f2d5a5ab838e4271bdb8d28fea97aaa.tar.gz
On 'xmllite' branch: Merge changes from trunk.
git-svn-id: https://svn.apache.org/repos/asf/apr/apr/branches/xmllite@1859568 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68b9ca26a..004452d6b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,7 +55,7 @@ OPTION(APR_HAVE_IPV6 "IPv6 support" ON)
OPTION(INSTALL_PDB "Install .pdb files (if generated)" ON)
OPTION(APR_BUILD_TESTAPR "Build the test suite" OFF)
OPTION(TEST_STATIC_LIBS "Test programs use APR static libraries instead of shared libraries?" OFF)
-SET(MIN_WINDOWS_VER "Vista"
+SET(MIN_WINDOWS_VER "Windows7"
CACHE STRING "Minimum Windows version")
SET(LIBXML2_ICONV_INCLUDE_DIR ""
CACHE STRING "Directory with iconv include files for libxml2")
@@ -100,9 +100,9 @@ ELSE(APU_USE_XMLLITE)
ENDIF()
IF("${MIN_WINDOWS_VER}" STREQUAL "")
- SET(win32_winnt_str "0x0600")
+ SET(win32_winnt_str "0x0601")
ELSEIF(${MIN_WINDOWS_VER} STREQUAL "Vista")
- SET(win32_winnt_str "0x0600")
+ MESSAGE(FATAL_ERROR "Minimum supported Windows version is Windows 7/Windows Server 2008 R2")
ELSEIF(${MIN_WINDOWS_VER} STREQUAL "Windows7")
SET(win32_winnt_str "0x0601")
ELSE()