summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Zhakov <ivan@apache.org>2019-09-14 09:32:03 +0000
committerIvan Zhakov <ivan@apache.org>2019-09-14 09:32:03 +0000
commitd9e0d024df1501868a5986525669432e8b50c638 (patch)
treed82096d0c77afa03ee621b7875d0c756f8021eb2 /CMakeLists.txt
parentfa844cac0e095cec551cfb0b1e7cea2d32b2375c (diff)
downloadapr-d9e0d024df1501868a5986525669432e8b50c638.tar.gz
win32: Do not use TransmitFile directly. According to documentation
TransmitFile() should not be used directly and pointer to function should retrieved using WSAIoctl: https://docs.microsoft.com/en-gb/windows/win32/api/mswsock/nf-mswsock-transmitfile#remarks * network_io/win32/sendrecv.c (apr_socket_sendfile): Retrieve pointer to TransmitFile using WSAIoctl. * CMakeLists.txt (APR_SYSTEM_LIBS): Remove reference to mswsock.lib. git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1866932 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e34afe03..c731fc816 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -160,7 +160,6 @@ SET(APR_INCLUDE_DIRECTORIES
SET(APR_SYSTEM_LIBS
ws2_32
- mswsock
rpcrt4
bcrypt
)