summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Zhakov <ivan@apache.org>2022-11-23 14:15:06 +0000
committerIvan Zhakov <ivan@apache.org>2022-11-23 14:15:06 +0000
commite8f7b919fac2f71c78edc3d3c9d3f6547aac92e4 (patch)
tree2cf3224a684f29f35dcef43c432f27cc1e53504c /CMakeLists.txt
parent9a59558b0ace38a3b4c9dae36452b1312f74f437 (diff)
downloadapr-e8f7b919fac2f71c78edc3d3c9d3f6547aac92e4.tar.gz
* CMakeLists.txt: Make CMAKE_MINIMUM_REQUIRED the first directive as
required by CMake documentation [1] [1] https://cmake.org/cmake/help/latest/command/cmake_minimum_required.html git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1905493 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8520e77ca..41d03fff6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,10 +15,12 @@
#
# Read README.cmake before using this.
-PROJECT(APR C)
-
+# CMAKE_MINIMUM_REQUIRED should be the first directive in the file:
+# https://cmake.org/cmake/help/latest/command/cmake_minimum_required.html
CMAKE_MINIMUM_REQUIRED(VERSION 3.0)
+PROJECT(APR C)
+
# Enable support for MSVC runtime library selection by abstraction
# if supported by CMake.
IF(POLICY CMP0091)