summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGraham Leggett <minfrin@apache.org>2019-12-26 01:18:53 +0000
committerGraham Leggett <minfrin@apache.org>2019-12-26 01:18:53 +0000
commit374210c50ee9f4dbf265f0172dcf2d45b97d0550 (patch)
treedcbfab4abc4b8f592c447a55aa4526ffec7d5a8a /configure.in
parenta531221366785bbd8ed99e39fc36db1ced26f8ef (diff)
downloadapr-374210c50ee9f4dbf265f0172dcf2d45b97d0550.tar.gz
Use AC_CHECK_SIZEOF, so as to support cross compiling. PR 56053.
git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1871980 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 0e2b08e30..c49b9196e 100644
--- a/configure.in
+++ b/configure.in
@@ -1725,7 +1725,7 @@ else
socklen_t_value="int"
fi
-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>], pid_t, 8)
+AC_CHECK_SIZEOF(pid_t)
if test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_short"; then
pid_t_fmt='#define APR_PID_T_FMT "hd"'
@@ -1797,7 +1797,7 @@ APR_CHECK_TYPES_FMT_COMPATIBLE(size_t, unsigned long, lu, [size_t_fmt="lu"], [
APR_CHECK_TYPES_FMT_COMPATIBLE(size_t, unsigned int, u, [size_t_fmt="u"])
])
-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>], ssize_t, 8)
+AC_CHECK_SIZEOF(ssize_t)
dnl the else cases below should no longer occur;
AC_MSG_CHECKING([which format to use for apr_ssize_t])
@@ -1815,7 +1815,7 @@ fi
ssize_t_fmt="#define APR_SSIZE_T_FMT \"$ssize_t_fmt\""
-APR_CHECK_SIZEOF_EXTENDED([#include <stddef.h>], size_t, 8)
+AC_CHECK_SIZEOF(size_t)
# else cases below should no longer occur;
AC_MSG_CHECKING([which format to use for apr_size_t])
@@ -1833,7 +1833,7 @@ fi
size_t_fmt="#define APR_SIZE_T_FMT \"$size_t_fmt\""
-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>], off_t, 8)
+AC_CHECK_SIZEOF(off_t)
if test "${ac_cv_sizeof_off_t}${apr_cv_use_lfs64}" = "4yes"; then
# Enable LFS
@@ -1933,7 +1933,7 @@ case $host in
;;
*)
ino_t_value=ino_t
- APR_CHECK_SIZEOF_EXTENDED(AC_INCLUDES_DEFAULT, ino_t, $ac_cv_sizeof_long)
+ AC_CHECK_SIZEOF(ino_t)
if test $ac_cv_sizeof_ino_t = 4; then
if test $ac_cv_sizeof_long = 4; then
ino_t_value="unsigned long"
@@ -1953,8 +1953,8 @@ else
bigendian=0
fi
-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>
-#include <sys/uio.h>],struct iovec,0)
+AC_CHECK_SIZEOF(struct iovec,,[AC_INCLUDES_DEFAULT
+#include <sys/uio.h>])
if test "$ac_cv_sizeof_struct_iovec" = "0"; then
have_iovec=0
else