summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2023-01-17 09:04:01 +0000
committerJoe Orton <jorton@apache.org>2023-01-17 09:04:01 +0000
commit5a86456a1f9f0c658c9665bfd5c59bd2c9cea825 (patch)
tree34f43a2d6df61a35f96036a41e2c64d4e76d462c /configure.in
parent71b69f8385af536787e2bb0048f19b5429722018 (diff)
downloadapr-5a86456a1f9f0c658c9665bfd5c59bd2c9cea825.tar.gz
Further strict C99 configure fix:
Avoid an implicit int in the definition of the main function. Avoids build problems with future C compilers which will not support them by default. Submitted by: Florian Weimer <fweimer redhat.com> PR: 66426 git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1906723 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ab3f27db0..0e31a5b3b 100644
--- a/configure.in
+++ b/configure.in
@@ -2316,7 +2316,7 @@ AC_TRY_RUN([
#include <sys/time.h>
#include <sys/resource.h>
#include <stdlib.h>
-main()
+int main(void)
{
struct rlimit limit;
limit.rlim_cur = 0;