summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorYann Ylavic <ylavic@apache.org>2018-07-25 11:00:50 +0000
committerYann Ylavic <ylavic@apache.org>2018-07-25 11:00:50 +0000
commit73fb267151d5f124e1ab931aee9f9e5d1d15be87 (patch)
tree61143845bfad3ea86e27ea7c8ff5603b36a86c08 /configure.in
parent71a0891e73e3d94a72e363b9e265bb4647b4194d (diff)
downloadapr-73fb267151d5f124e1ab931aee9f9e5d1d15be87.tar.gz
Provide APR_SIZEOF_OFF_T.
git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1836616 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9bcecd61e..6f56b8f99 100644
--- a/configure.in
+++ b/configure.in
@@ -1832,6 +1832,7 @@ if test "${ac_cv_sizeof_off_t}${apr_cv_use_lfs64}" = "4yes"; then
off_t_fmt='#define APR_OFF_T_FMT APR_INT64_T_FMT'
off_t_value='off64_t'
off_t_strfn='apr_strtoi64'
+ off_t_size=8
elif test "${ac_cv_sizeof_off_t}x${ac_cv_sizeof_long}" = "4x4"; then
# Special case: off_t may change size with _FILE_OFFSET_BITS
# on 32-bit systems with LFS support. To avoid compatibility
@@ -1840,8 +1841,10 @@ elif test "${ac_cv_sizeof_off_t}x${ac_cv_sizeof_long}" = "4x4"; then
off_t_value=long
off_t_fmt='#define APR_OFF_T_FMT "ld"'
off_t_strfn='strtol'
+ off_t_size="$ac_cv_sizeof_long"
elif test "$ac_cv_type_off_t" = "yes"; then
off_t_value=off_t
+ off_t_size="$ac_cv_sizeof_off_t"
# off_t is more commonly a long than an int; prefer that case
# where int and long are the same size.
if test "$ac_cv_sizeof_off_t" = "$ac_cv_sizeof_long"; then
@@ -1862,6 +1865,7 @@ elif test "$ac_cv_type_off_t" = "yes"; then
off_t_value=apr_int64_t
off_t_fmt='#define APR_OFF_T_FMT "I64d"'
off_t_strfn='_strtoi64'
+ off_t_size=8
;;
esac
else
@@ -1869,9 +1873,11 @@ else
off_t_value=int
off_t_fmt='#define APR_OFF_T_FMT "d"'
off_t_strfn='strtoi'
+ off_t_size=4
fi
AC_MSG_RESULT($off_t_value)
+
# Regardless of whether _LARGEFILE64_SOURCE is used, on some
# platforms _FILE_OFFSET_BITS will affect the size of ino_t and hence
# the build-time ABI may be different from the apparent ABI when using
@@ -1942,6 +1948,7 @@ AC_SUBST(bigendian)
AC_SUBST(aprlfs)
AC_SUBST(have_iovec)
AC_SUBST(ino_t_value)
+AC_SUBST(off_t_size)
dnl ----------------------------- Checking for string functions
AC_CHECK_FUNCS(strnicmp, have_strnicmp="1", have_strnicmp="0")