summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGraham Leggett <minfrin@apache.org>2020-02-05 08:40:57 +0000
committerGraham Leggett <minfrin@apache.org>2020-02-05 08:40:57 +0000
commit7e7899c6834b83f4b147daaadfdbd4fb5531507d (patch)
tree7a110b4460225414ca2ffbca31907fdb5580ece8 /configure.in
parentf67e21c546c21896ab458bd9d88c78f30f962b11 (diff)
downloadapr-7e7899c6834b83f4b147daaadfdbd4fb5531507d.tar.gz
Don't try to use PROC_PTHREAD by default when cross compiling.
git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1873593 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 182cd6262..2d44cafd5 100644
--- a/configure.in
+++ b/configure.in
@@ -2351,8 +2351,8 @@ APR_IFALLYES(func:semget func:semctl func:semop define:SEM_UNDO,
APR_IFALLYES(header:OS.h func:create_sem func:acquire_sem func:acquire_sem_etc,
APR_DECIDE(USE_BEOSSEM, [BeOS Semaphores]))
# pthread mutex both pshared and robust[_np] is the best default
-case "$apr_cv_mutex_robust_shared" in
-"yes"|"np")
+case "$hasprocpthreadser:$apr_cv_mutex_robust_shared" in
+"1:yes" | "1:np")
APR_DECIDE(USE_PROC_PTHREAD_SERIALIZE, [pthread pshared mutex])
;;
*)
@@ -2371,21 +2371,27 @@ procpthreadser="0"
fcntlser="0"
case $ac_decision in
USE_FLOCK_SERIALIZE )
+ hasflockser="1"
flockser="1"
;;
USE_FCNTL_SERIALIZE )
+ hasfcntlser="1"
fcntlser="1"
;;
USE_SYSVSEM_SERIALIZE )
+ hassysvser="1"
sysvser="1"
;;
USE_POSIXSEM_SERIALIZE )
+ hasposixser="1"
posixser="1"
;;
USE_PROC_PTHREAD_SERIALIZE )
+ hasprocpthreadser="1"
procpthreadser="1"
;;
USE_BEOSSEM )
+ hasbeossem="1"
beossem="1"
;;
esac