summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Reid <dreid@apache.org>2000-11-06 14:19:00 +0000
committerDavid Reid <dreid@apache.org>2000-11-06 14:19:00 +0000
commit973276d792006f8b5c3659f926d4edc8be07b1a5 (patch)
tree1d6c3a1d88c83f05d40c21445456b5eda7b32c8d /configure.in
parentce342e9ad72c6cc08fbcc1b6c3ec076d21e147e6 (diff)
downloadapr-973276d792006f8b5c3659f926d4edc8be07b1a5.tar.gz
This commit adds the start of IPv6 support. Before we all get too excited,
please note that it doesn't do anything at present. All this adds is the configure checks and a few variables that will be used by the code. Can anyone on an IPv6 system please see how these work and report any problems so we can refine our plans before we submit the next patch? Thanks. Systems tested so far are FreeBSD 4, Mandrake 7 and Solaris 8. Reviewed by: Jeff Trawick git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@60636 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4b2913ca0..5bb7b2a04 100644
--- a/configure.in
+++ b/configure.in
@@ -699,8 +699,21 @@ fi
AC_SUBST(have_in_addr)
AC_SUBST(file_as_socket)
+AC_CHECK_FUNCS(inet_pton)
+AC_CHECK_FUNCS(inet_ntop)
+APR_CHECK_SOCKADDR_SA_LEN
+
APR_CHECK_GETHOSTBYNAME_NAS
+echo "${nl}IPv6 Networking support??"
+dnl # Start of checking for IPv6 support...
+AC_SEARCH_LIBS(getaddrinfo, inet6)
+AC_CHECK_FUNCS(getaddrinfo)
+AC_CHECK_FUNCS(getipnodebyname)
+AC_CHECK_FUNCS(getipnodebyaddr)
+APR_CHECK_SOCKADDR_IN6
+AC_SUBST(have_sockaddr_in6)
+
dnl #----------------------------- Construct the files
AC_SUBST(LDLIBS)
@@ -715,7 +728,7 @@ AC_SUBST(EXEEXT)
AC_SUBST(THREAD_CPPFLAGS)
AC_SUBST(THREAD_CFLAGS)
-echo "Construct Makefiles and header files."
+echo "${nl}${nl}Construct Makefiles and header files."
MAKEFILE1="Makefile lib/Makefile strings/Makefile passwd/Makefile tables/Makefile"
SUBDIRS="lib strings passwd tables "
for dir in $MODULES