summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStefan Fritsch <sf@apache.org>2014-05-09 20:14:01 +0000
committerStefan Fritsch <sf@apache.org>2014-05-09 20:14:01 +0000
commit9aaf97b879e299996f5f5c234ca4ce763c35f715 (patch)
tree8fe918da87eae062d76faeb55e7b77643733bbe5 /configure.in
parentda648924018272297d940d1e7725c02c568210a1 (diff)
downloadapr-9aaf97b879e299996f5f5c234ca4ce763c35f715.tar.gz
Option to detect concurrent accesses to pools
Enabled by new configure option --enable-pool-concurrency-check. Compared to pool-owner-debugging, this only detects cases where there is actual contention between accesses. The advantage is that runtime costs should be relatively low. The diagnostic messages could still use some improvement. git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1593614 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bd86b30bf..e8fe8d21f 100644
--- a/configure.in
+++ b/configure.in
@@ -1492,6 +1492,14 @@ AC_ARG_ENABLE(allocator-uses-mmap,
fi ]
)
+AC_ARG_ENABLE(pool-concurrency-check,
+ [ --enable-pool-concurrency-check Check for concurrent usage of memory pools],
+ [ if test "$enableval" = "yes"; then
+ AC_DEFINE(APR_POOL_CONCURRENCY_CHECK, 1,
+ [Define if pool functions should abort if concurrent usage is detected])
+ fi ]
+)
+
dnl ----------------------------- Checks for standard typedefs
AC_TYPE_OFF_T
AC_TYPE_PID_T