summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJim Jagielski <jim@apache.org>2020-10-29 20:16:55 +0000
committerJim Jagielski <jim@apache.org>2020-10-29 20:16:55 +0000
commit9d9c6990afaa7ad8eea0be524481bb48a5dd1b09 (patch)
tree9204fc3075dc3207c6ada0db49ef103c5787ae5b /configure.in
parent777acc63312de2b4d9eef6183c09957a5c4e9e06 (diff)
downloadapr-9d9c6990afaa7ad8eea0be524481bb48a5dd1b09.tar.gz
calls to exit() require stdlib.h or else we get -Werror,-Wimplicit-function-declaration
git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1882979 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 937bc22ba..2d586f4c8 100644
--- a/configure.in
+++ b/configure.in
@@ -2192,6 +2192,7 @@ AC_TRY_RUN([
#include <sys/types.h>
#include <sys/time.h>
#include <sys/resource.h>
+#include <stdlib.h>
main()
{
struct rlimit limit;
@@ -2292,6 +2293,7 @@ if test "$threads" = "1"; then
AC_TRY_RUN([
#include <sys/types.h>
#include <pthread.h>
+#include <stdlib.h>
int main()
{
pthread_mutex_t mutex;
@@ -2421,7 +2423,9 @@ AC_TRY_RUN([
#endif
#include <fcntl.h>
#include <errno.h>
-
+#ifdef HAVE_STDLIB_H
+#include <stdlib.h>
+#endif
int fd;
struct flock proc_mutex_lock_it = {0};
const char *fname = "conftest.fcntl";