summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGraham Leggett <minfrin@apache.org>2019-08-17 10:09:32 +0000
committerGraham Leggett <minfrin@apache.org>2019-08-17 10:09:32 +0000
commita1e6225e65054e86efd1908f9d4470e7d033783b (patch)
treed564820f91e73d5094392bf0dabccebd488fdf0b /configure.in
parentb6e316942278593c493d9077a64dd08bab527b9b (diff)
downloadapr-a1e6225e65054e86efd1908f9d4470e7d033783b.tar.gz
Add --tag=CC to libtool invocations. PR 62640.
git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1865343 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e40b05382..0e2b08e30 100644
--- a/configure.in
+++ b/configure.in
@@ -297,9 +297,9 @@ AC_ARG_WITH(libtool, [ --without-libtool avoid using libtool to link the
[ use_libtool=$withval ], [ use_libtool="yes" ] )
if test "x$use_libtool" = "xyes"; then
- lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -o $@ -c $< && touch $@'
+ lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile --tag=CC $(COMPILE) -o $@ -c $< && touch $@'
LT_VERSION="-version-info `$get_version libtool $version_hdr APR`"
- link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(COMPILE) \$(LT_LDFLAGS) \$(LT_VERSION) \$(ALL_LDFLAGS) -o \$@"
+ link="\$(LIBTOOL) \$(LTFLAGS) --mode=link --tag=CC \$(COMPILE) \$(LT_LDFLAGS) \$(LT_VERSION) \$(ALL_LDFLAGS) -o \$@"
so_ext='lo'
lib_target='-rpath $(libdir) $(OBJECTS)'
export_lib_target='-rpath \$(libdir) \$(OBJECTS)'