summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2023-01-11 09:42:18 +0000
committerJoe Orton <jorton@apache.org>2023-01-11 09:42:18 +0000
commitd5c2a64628c4a8731d69c92d816f39be0ab5f71a (patch)
tree03996caf5f70dbf2bb083fa0ff8cc67785be45a4 /configure.in
parent2729a1d6885c03b07360936d0958bb75a735f093 (diff)
downloadapr-d5c2a64628c4a8731d69c92d816f39be0ab5f71a.tar.gz
Fix further strict C99 compliance issue. (fixes #37)
PR: 66408 Submitted by: Sam James <sam gentoo.org> git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1906594 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 653d2597b..ab3f27db0 100644
--- a/configure.in
+++ b/configure.in
@@ -1477,8 +1477,6 @@ AC_CHECK_FUNCS(sigaction, [ have_sigaction="1" ], [ have_sigaction="0" ])
AC_DECL_SYS_SIGLIST
AC_CHECK_FUNCS(fork, [ fork="1" ], [ fork="0" ])
-APR_CHECK_INET_ADDR
-APR_CHECK_INET_NETWORK
AC_SUBST(apr_inaddr_none)
AC_CHECK_FUNC(_getch)
AC_CHECK_FUNCS(strerror_r, [ strerror_r="1" ], [ strerror_r="0" ])
@@ -1601,6 +1599,9 @@ else
mswsockh=0
fi
+APR_CHECK_INET_ADDR
+APR_CHECK_INET_NETWORK
+
# IRIX 6.5 has a problem in <netinet/tcp.h> which prevents it from
# being included by itself. Check for <netinet/tcp.h> manually,
# including another header file first.
@@ -2355,7 +2356,7 @@ AC_TRY_RUN([
#ifndef SEM_FAILED
#define SEM_FAILED (-1)
#endif
-main()
+int main()
{
sem_t *psem;
const char *sem_name = "/apr_autoconf";
@@ -2552,6 +2553,8 @@ int fd;
struct flock proc_mutex_lock_it = {0};
const char *fname = "conftest.fcntl";
+int lockit();
+
int main()
{
int rc, status;;