summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRainer Jung <rjung@apache.org>2016-02-12 17:20:22 +0000
committerRainer Jung <rjung@apache.org>2016-02-12 17:20:22 +0000
commit3244dd32544cf68068f80ef09d647a13be388bac (patch)
treef325980781a8761106d965fead712ecb53e36211 /CMakeLists.txt
parent79f068d00c8a5eb54796b981284de5cbea0bd676 (diff)
downloadhttpd-3244dd32544cf68068f80ef09d647a13be388bac.tar.gz
More mod_proxy_http2 build support:
- include in Windows and Netware LoadModule lists - add to cmake build file Untested. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1730075 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6aa260404..3ea412f02d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -334,6 +334,7 @@ SET(MODULE_LIST
"modules/proxy/mod_proxy_http+I+Apache proxy HTTP module. Requires and is enabled by --enable-proxy."
"modules/proxy/mod_proxy_scgi+I+Apache proxy SCGI module. Requires and is enabled by --enable-proxy."
"modules/proxy/mod_proxy_wstunnel+I+Apache proxy Websocket Tunnel module. Requires and is enabled by --enable-proxy."
+ "modules/http2/mod_proxy_http2+i+Apache proxy HTTP/2 module. Requires --enable-proxy."
"modules/proxy/mod_serf+O+Reverse proxy module using Serf"
"modules/session/mod_session+I+session module"
"modules/session/mod_session_cookie+I+session cookie module"
@@ -450,6 +451,14 @@ IF(LIBXML2_FOUND)
ENDIF()
SET(mod_proxy_scgi_extra_libs mod_proxy)
SET(mod_proxy_wstunnel_extra_libs mod_proxy)
+SET(mod_proxy_http2_requires NGHTTP2_FOUND)
+SET(mod_proxy_http2_extra_defines ssize_t=long)
+SET(mod_proxy_http2_extra_libs ${NGHTTP2_LIBRARIES})
+SET(mod_proxy_http2_extra_sources
+ modules/http2/h2_proxy_session.c modules/http2/h2_request.c
+ modules/http2/h2_util.c
+)
+SET(mod_proxy_http2_extra_libs mod_proxy)
SET(mod_ratelimit_extra_defines AP_RL_DECLARE_EXPORT)
SET(mod_sed_extra_sources
modules/filters/regexp.c modules/filters/sed0.c