summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Zhakov <ivan@apache.org>2022-11-29 14:47:15 +0000
committerIvan Zhakov <ivan@apache.org>2022-11-29 14:47:15 +0000
commit346359d7090bd191cc04478d3d62382c044c00a1 (patch)
treedef4e158a634a44875797419140bdcf77f770915 /CMakeLists.txt
parentccf9197926e25d11d8786df3dd39cb1b931f11b5 (diff)
downloadhttpd-346359d7090bd191cc04478d3d62382c044c00a1.tar.gz
* CMakeLists.txt: Make CMAKE_MINIMUM_REQUIRED the first directive as
required by CMake documentation [1] [1] https://cmake.org/cmake/help/latest/command/cmake_minimum_required.html git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1905611 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a16c71d1b..e77a70c6e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,10 +15,12 @@
#
# Read README.cmake before using this.
-PROJECT(HTTPD C)
-
+# CMAKE_MINIMUM_REQUIRED should be the first directive in the file:
+# https://cmake.org/cmake/help/latest/command/cmake_minimum_required.html
CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
+PROJECT(HTTPD C)
+
INCLUDE(CheckSymbolExists)
INCLUDE(CheckCSourceCompiles)