summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Eissing <icing@apache.org>2022-04-04 08:24:09 +0000
committerStefan Eissing <icing@apache.org>2022-04-04 08:24:09 +0000
commit4442201e61616a2a75909b26909121f469bfae7c (patch)
tree63f3ea4cfe577f6892cd704c0ac4f719bc985093 /CMakeLists.txt
parenta6ed77c35e71805db39f79a9d8e171bb7737e712 (diff)
downloadhttpd-4442201e61616a2a75909b26909121f469bfae7c.tar.gz
*) core/mod_http/mod_http2:
- adds new meta bucket types REQUEST, RESPONSE and HEADERS to the API. - adds a new method for setting standard response headers Date and Server - adds helper methods for formatting parts of HTTP/1.x, like headers and end chunks for use in non-core parts of the server, e.g. mod_proxy - splits the HTTP_IN filter into a "generic HTTP" and "specific HTTP/1.x" filter. The latter one named HTTP1_BODY_IN. - Uses HTTP1_BODY_IN only for requests with HTTP version <= 1.1 - Removes the chunked input simulation from mod_http2 - adds body_indeterminate flag to request_rec that indicates that a request body may be present and needs to be read/discarded. This replaces logic that thinks without Content-Length and Transfer-Encoding, no request body can exist. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1899547 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 71f992cfbb..8cc2eaa22c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -699,6 +699,7 @@ SET(LIBHTTPD_SOURCES
server/eoc_bucket.c
server/eor_bucket.c
server/error_bucket.c
+ server/headers_bucket.c
server/listen.c
server/log.c
server/mpm/winnt/child.c