summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeny Kotkov <kotkov@apache.org>2016-11-29 00:00:28 +0000
committerEvgeny Kotkov <kotkov@apache.org>2016-11-29 00:00:28 +0000
commit4b3a9443b53110ca7e25684a5bc61acdd5484be6 (patch)
tree805e015a103456e62f8c9af5598a880a33912c98 /CMakeLists.txt
parentd3c7e4780f257ce062347879b03b41160244be90 (diff)
downloadhttpd-4b3a9443b53110ca7e25684a5bc61acdd5484be6.tar.gz
mod_brotli: Update makefiles to use the library layout of the official
Brotli repository. With the recent update (https://github.com/google/brotli/pull/464), the official repository now produces pkg-config metadata files (brotli.pc), and has a fixed library layout (libbrotlicommon/libbrotlienc/libbrotlidec) on both Windows and Linux. Expect this layout in the makefiles, and take advantage of the pkg-config metadata, if it's available. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1771827 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 446c1f4e71..890618f465 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,8 +58,8 @@ ELSE()
SET(default_nghttp2_libraries "${CMAKE_INSTALL_PREFIX}/lib/nghttp2.lib")
ENDIF()
-IF(EXISTS "${CMAKE_INSTALL_PREFIX}/lib/brotli_enc.lib")
- SET(default_brotli_libraries "${CMAKE_INSTALL_PREFIX}/lib/brotli_enc.lib" "${CMAKE_INSTALL_PREFIX}/lib/brotli_common.lib")
+IF(EXISTS "${CMAKE_INSTALL_PREFIX}/lib/brotlienc.lib")
+ SET(default_brotli_libraries "${CMAKE_INSTALL_PREFIX}/lib/brotlienc.lib" "${CMAKE_INSTALL_PREFIX}/lib/brotlicommon.lib")
ELSE()
SET(default_brotli_libraries)
ENDIF()