summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Eissing <icing@apache.org>2016-04-15 13:50:46 +0000
committerStefan Eissing <icing@apache.org>2016-04-15 13:50:46 +0000
commit52cdae53be08ed37e5d73eac20a39d76f7617bcb (patch)
treee383ea1324254aee627932931ee9dd5250f0444f /CMakeLists.txt
parent8c52bb1c1abb3aeba815a87d7c8b1e07d9b7ba79 (diff)
downloadhttpd-52cdae53be08ed37e5d73eac20a39d76f7617bcb.tar.gz
mod_http2: new bucket beams for tranporting buckets across threads without buffer copy. Code cleanup
git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1739303 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e68076630e..b33f11caab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -403,15 +403,13 @@ SET(mod_http2_extra_sources
modules/http2/h2_conn.c modules/http2/h2_conn_io.c
modules/http2/h2_ctx.c modules/http2/h2_filter.c
modules/http2/h2_from_h1.c modules/http2/h2_h2.c
- modules/http2/h2_io.c modules/http2/h2_io_set.c
+ modules/http2/h2_io.c modules/http2/h2_bucket_beam.c
modules/http2/h2_mplx.c modules/http2/h2_push.c
modules/http2/h2_request.c modules/http2/h2_response.c
modules/http2/h2_session.c modules/http2/h2_stream.c
modules/http2/h2_switch.c modules/http2/h2_ngn_shed.c
- modules/http2/h2_task.c modules/http2/h2_task_input.c
- modules/http2/h2_task_output.c modules/http2/h2_int_queue.c
- modules/http2/h2_util.c modules/http2/h2_worker.c
- modules/http2/h2_workers.c
+ modules/http2/h2_task.c modules/http2/h2_util.c
+ modules/http2/h2_worker.c modules/http2/h2_workers.c
)
SET(mod_ldap_extra_defines LDAP_DECLARE_EXPORT)
SET(mod_ldap_extra_libs wldap32)