summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Eissing <icing@apache.org>2016-05-12 15:04:18 +0000
committerStefan Eissing <icing@apache.org>2016-05-12 15:04:18 +0000
commit6846b98a6c775b9488d3660992b5f74f59884b82 (patch)
treef12fcadc749bf8c2405c712641ea35af7c98b714 /CMakeLists.txt
parentc9516818c9b5919d152f3dbf70de40d148ea7d3a (diff)
downloadhttpd-6846b98a6c775b9488d3660992b5f74f59884b82.tar.gz
applied mod_proxy_http2 related cmake biuld changes as proposed by Evgeny Kotkov
git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1743512 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d717635767..5aa6dc7d0e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -396,6 +396,7 @@ SET(mod_firehose_requires SOMEONE_TO_MAKE_IT_COMPILE_ON_WINDOWS)
SET(mod_heartbeat_extra_libs mod_watchdog)
SET(mod_http2_requires NGHTTP2_FOUND)
SET(mod_http2_extra_defines ssize_t=long)
+SET(mod_http2_extra_includes ${NGHTTP2_INCLUDE_DIR})
SET(mod_http2_extra_libs ${NGHTTP2_LIBRARIES})
SET(mod_http2_extra_sources
modules/http2/h2_alt_svc.c modules/http2/h2_bucket_eoc.c
@@ -451,11 +452,11 @@ SET(mod_proxy_scgi_extra_libs mod_proxy)
SET(mod_proxy_wstunnel_extra_libs mod_proxy)
SET(mod_proxy_http2_requires NGHTTP2_FOUND)
SET(mod_proxy_http2_extra_defines ssize_t=long)
-SET(mod_proxy_http2_extra_libs ${NGHTTP2_LIBRARIES})
+SET(mod_proxy_http2_extra_includes ${NGHTTP2_INCLUDE_DIR})
+SET(mod_proxy_http2_extra_libs ${NGHTTP2_LIBRARIES} mod_proxy)
SET(mod_proxy_http2_extra_sources
modules/http2/h2_proxy_session.c modules/http2/h2_util.c
)
-SET(mod_proxy_http2_extra_libs mod_proxy)
SET(mod_ratelimit_extra_defines AP_RL_DECLARE_EXPORT)
SET(mod_sed_extra_sources
modules/filters/regexp.c modules/filters/sed0.c