summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Eissing <icing@apache.org>2019-10-16 12:31:43 +0000
committerStefan Eissing <icing@apache.org>2019-10-16 12:31:43 +0000
commit77c96847ce410d47678f78cb543b1dae7db47112 (patch)
tree0e03267b354434394872c688d979b974393a7bc2 /CMakeLists.txt
parentc04b49387421a7c98c679e9262b629458c22db57 (diff)
downloadhttpd-77c96847ce410d47678f78cb543b1dae7db47112.tar.gz
*) mod_md: Adding the several new features.
The module offers an implementation of OCSP Stapling that can replace fully or for a limited set of domains the existing one from mod_ssl. OCSP handling is part of mod_md's monitoring and message notifications. If can be used for sites that do not have ACME certificates. The url for a CTLog Monitor can be configured. It is used in the server-status to link to the external status page of a certicate. The MDMessageCmd is called with argument "installed" when a new certificate has been activated on server restart/reload. This allows for processing of the new certificate, for example to applications that require it in different locations or formats. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1868506 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 546afe1a67..1c5621fb4f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -517,9 +517,10 @@ SET(mod_md_extra_sources
modules/md/md_result.c modules/md/md_reg.c
modules/md/md_status.c modules/md/md_store.c
modules/md/md_store_fs.c modules/md/md_time.c
- modules/md/md_util.c
+ modules/md/md_ocsp.c modules/md/md_util.c
modules/md/mod_md_config.c modules/md/mod_md_drive.c
modules/md/mod_md_os.c modules/md/mod_md_status.c
+ modules/md/mod_md_ocsp.c
)
SET(mod_optional_hook_export_extra_defines AP_DECLARE_EXPORT) # bogus reuse of core API prefix
SET(mod_proxy_extra_defines PROXY_DECLARE_EXPORT)