summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeff Trawick <trawick@apache.org>2014-09-16 01:21:24 +0000
committerJeff Trawick <trawick@apache.org>2014-09-16 01:21:24 +0000
commitb30b4c31072b6ee53a5426019f6f676071c706c9 (patch)
tree0de37abbe13176b41b07cce7c5cec482386d2bd8 /CMakeLists.txt
parent0c1468c4e9961ae81e4b42d5fa179e9f4f418204 (diff)
downloadhttpd-b30b4c31072b6ee53a5426019f6f676071c706c9.tar.gz
Fix a cmake compatiblity issue related to quoting with cmake 2.8.12
and later. PR: 56615 Submitted by: Chuck Liu <cliu81 gmail.com>, trawick git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1625196 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba6f1d0c2b..082241f699 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,11 +80,11 @@ FOREACH(onelib ${APR_LIBRARIES})
ENDFOREACH()
MACRO(DEFINE_WITH_BLANKS output_definition input_symbol input_value)
- IF(MSVC_IDE)
+ IF(MSVC_IDE OR ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION} VERSION_GREATER 2.8.11)
SET(${output_definition} "-D${input_symbol}=\"${input_value}\"")
ELSE()
- # assume command-line tool, where extra quotes must be added and escaped to
- # survive
+ # command-line tool + older cmake, where extra quotes must be added and
+ # escaped to survive
SET(${output_definition} "-D${input_symbol}=\"\\\"${input_value}\\\"\"")
ENDIF()
ENDMACRO()