summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormanu <manu@unknown>2023-02-13 16:48:35 +0000
committermanu <manu@unknown>2023-02-13 16:48:35 +0000
commitbed50350e49fd6bde43458c9d71db5853c8abd88 (patch)
tree1efd61b576b4b1ef114a319ed19ffaa3cef33ab1 /CMakeLists.txt
parent7e5010b3cbfb25f5347ac888bf8961e41556b8f1 (diff)
downloadhttpd-bed50350e49fd6bde43458c9d71db5853c8abd88.tar.gz
Add MS-WDV support
MS-WDV specification: https://learn.microsoft.com/en-us/openspecs/windows_protocols/ms-wdv The changes introduces the DAVMSext directive, which is used to enable MS-WDV: DAVMSext +WDV dav_get_timeout_string() is introduced as a variant of dav_get_timeout(). The former parses a string, the later parse the Timeout HTTP header. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1907608 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7f9a69d30..9b920efac1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -450,6 +450,7 @@ SET(mod_dav_extra_sources
modules/dav/main/liveprop.c modules/dav/main/props.c
modules/dav/main/std_liveprop.c modules/dav/main/providers.c
modules/dav/main/util.c modules/dav/main/util_lock.c
+ modules/dav/mail/ms_wdv.c
)
SET(mod_dav_install_lib 1)
SET(mod_dav_fs_extra_sources