summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeff Trawick <trawick@apache.org>2013-09-30 13:56:20 +0000
committerJeff Trawick <trawick@apache.org>2013-09-30 13:56:20 +0000
commitc43ffe39076bb4503c39ca463fc6d9f69f644a93 (patch)
tree20be404bb65204f918baa82c5f030dd10b7c025c /CMakeLists.txt
parent79f70135fbcfd1feab529291af56f0636ba7d533 (diff)
downloadhttpd-c43ffe39076bb4503c39ca463fc6d9f69f644a93.tar.gz
Follow up to r1527295:
ssl_engine_dh.c is still in 2.4.x, and (perhaps unexpectedly) this cmake list supports both trunk and 2.4.x for the time being. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1527570 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3965939785..643067ef2d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -426,6 +426,11 @@ SET(mod_ssl_extra_sources
modules/ssl/ssl_util.c modules/ssl/ssl_util_ocsp.c
modules/ssl/ssl_util_ssl.c modules/ssl/ssl_util_stapling.c
)
+IF(${minorversion} STREQUAL "4")
+ SET(mod_ssl_extra_sources
+ ${mod_ssl_extra_sources} modules/ssl/ssl_engine_dh.c
+ )
+ENDIF()
SET(mod_status_extra_defines STATUS_DECLARE_EXPORT)
SET(mod_watchdog_install_lib 1)
SET(mod_xml2enc_requires LIBXML2_FOUND)