summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Jagielski <jim@apache.org>2018-08-09 11:30:10 +0000
committerJim Jagielski <jim@apache.org>2018-08-09 11:30:10 +0000
commitca78ac0107b0515b7daafd6e9ce52513f6bde4e1 (patch)
treeeee65f1c29b3955ee77d9e512f3ec9eb43c93fad /CMakeLists.txt
parented521579496724570446484fa524a023518cdcb5 (diff)
downloadhttpd-ca78ac0107b0515b7daafd6e9ce52513f6bde4e1.tar.gz
Patch PR 62567. Fix by Michal Karm Babacek <michal.babacek gmail.com>
git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1837717 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3da3fcb53b..e630d112d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -977,11 +977,11 @@ SET(rel_runtimedir "logs")
SET(rel_sysconfdir "conf")
FILE(GLOB_RECURSE conffiles RELATIVE ${CMAKE_SOURCE_DIR}/docs/conf "docs/conf/*")
FOREACH(template ${conffiles})
- STRING(REPLACE ".conf.in" ".conf" conf ${template})
+ STRING(REPLACE ".conf.in" ".conf" conf "${template}")
FILE(READ "docs/conf/${template}" template_text)
IF(template MATCHES ".conf.in$")
# substitute @var@/@@var@@ in .conf.in
- STRING(REPLACE "@@" "@" template_text ${template_text})
+ STRING(REPLACE "@@" "@" template_text "${template_text}")
STRING(CONFIGURE "${template_text}" template_text @ONLY)
ENDIF()
FILE(WRITE ${CMAKE_BINARY_DIR}/conf/original/${conf} "${template_text}")