summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJim Jagielski <jim@apache.org>2017-10-02 15:29:14 +0000
committerJim Jagielski <jim@apache.org>2017-10-02 15:29:14 +0000
commit00f7c2abcb8c8d3a6d67abd9473a4cb7f8926c44 (patch)
tree54861f6ed376908394e25f865d4451082c405116 /configure.in
parente2848831fea510afbf2922ef0ad72285b9af9594 (diff)
downloadhttpd-00f7c2abcb8c8d3a6d67abd9473a4cb7f8926c44.tar.gz
Get maintainer-mode working again w/ clang-900
git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1810448 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ef7bd02482..43a5053fe8 100644
--- a/configure.in
+++ b/configure.in
@@ -630,6 +630,11 @@ AC_ARG_ENABLE(maintainer-mode,APACHE_HELP_STRING(--enable-maintainer-mode,Turn o
APR_ADDTO(CPPFLAGS, -DAP_DEBUG)
if test "$GCC" = "yes"; then
APR_ADDTO(CFLAGS,[-Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Wpointer-arith])
+ case `($CC --version) 2>/dev/null` in
+ *clang-900*)
+ APACHE_ADD_GCC_CFLAG([-Wno-error=strict-prototypes])
+ ;;
+ esac
APACHE_ADD_GCC_CFLAG([-std=c89])
APACHE_ADD_GCC_CFLAG([-Werror])
APACHE_ADD_GCC_CFLAG([-Wdeclaration-after-statement])
@@ -656,6 +661,11 @@ AC_ARG_ENABLE(debugger-mode,APACHE_HELP_STRING(--enable-debugger-mode,Turn on de
APR_ADDTO(CPPFLAGS, -DAP_DEBUG)
if test "$GCC" = "yes"; then
APR_ADDTO(CFLAGS,[-Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Wpointer-arith -O0])
+ case `($CC --version) 2>/dev/null` in
+ *clang-900*)
+ APACHE_ADD_GCC_CFLAG([-Wno-error=strict-prototypes])
+ ;;
+ esac
APACHE_ADD_GCC_CFLAG([-Wdeclaration-after-statement])
APACHE_ADD_GCC_CFLAG([-Werror=declaration-after-statement])
APACHE_ADD_GCC_CFLAG([-Wformat])