summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRuediger Pluem <rpluem@apache.org>2023-01-04 13:42:35 +0000
committerRuediger Pluem <rpluem@apache.org>2023-01-04 13:42:35 +0000
commit05297d7b00f0cb1f20d3ff14f4409097df2615fe (patch)
tree1a4380dd55140350400394710f70b0d53d96274f /configure.in
parent47a3f2329ce4229c7f12846460b0eb56bf3a6ee6 (diff)
downloadhttpd-05297d7b00f0cb1f20d3ff14f4409097df2615fe.tar.gz
Use 'command -v' instead of 'which' which is more portable.
git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1906387 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index dbc9ea8536..4989ec3404 100644
--- a/configure.in
+++ b/configure.in
@@ -224,13 +224,13 @@ AC_ARG_WITH(pcre,
APACHE_HELP_STRING(--with-pcre=PATH,Use external PCRE library))
if test "x$with_pcre" = "x" || test "$with_pcre" = "yes"; then
with_pcre="$PATH"
-else if which $with_pcre 2>/dev/null; then :; else
+else if command -v $with_pcre 2>/dev/null; then :; else
with_pcre="$with_pcre/bin:$with_pcre"
fi
fi
AC_CHECK_TARGET_TOOLS(PCRE_CONFIG, [pcre2-config pcre-config],
- [`which $with_pcre 2>/dev/null`], $with_pcre)
+ [`command -v $with_pcre 2>/dev/null`], $with_pcre)
if test "x$PCRE_CONFIG" != "x"; then
if $PCRE_CONFIG --version >/dev/null 2>&1; then :; else