summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2019-06-21 13:30:17 +0000
committerJoe Orton <jorton@apache.org>2019-06-21 13:30:17 +0000
commit07e3fbd647bc9ed047eca8bf8fc22eae47d97daa (patch)
treeba1ec1f2116bd55316b2c862d8354478b8de563e /configure.in
parent908ac62063482e9c5a7c7b1be0de6bb0b31435c4 (diff)
downloadhttpd-07e3fbd647bc9ed047eca8bf8fc22eae47d97daa.tar.gz
* configure.in, acinclude.m4: Inline APACHE_GEN_MAKEFILES in AC_CONFIG_COMMANDS
and run during the "normal" phase of ./config.status rather than as init-cmds. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1861787 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 78d133f411..6c8a6d4886 100644
--- a/configure.in
+++ b/configure.in
@@ -1045,7 +1045,12 @@ dnl Ensure that docs/conf is created.
test -d docs/conf||$mkdir_p docs/conf
AC_CONFIG_FILES(docs/conf/httpd.conf docs/conf/extra/httpd-autoindex.conf docs/conf/extra/httpd-dav.conf docs/conf/extra/httpd-default.conf docs/conf/extra/httpd-info.conf docs/conf/extra/httpd-languages.conf docs/conf/extra/httpd-manual.conf docs/conf/extra/httpd-mpm.conf docs/conf/extra/httpd-multilang-errordoc.conf docs/conf/extra/httpd-policy.conf docs/conf/extra/httpd-ssl.conf docs/conf/extra/httpd-userdir.conf docs/conf/extra/httpd-vhosts.conf docs/conf/extra/proxy-html.conf docs/conf/extra/httpd-macro.conf include/ap_config_layout.h support/apxs support/apachectl support/dbmmanage support/envvars-std support/log_server_status support/logresolve.pl support/phf_abuse_log.cgi support/split-logfile build/rules.mk build/pkg/pkginfo build/config_vars.sh)
-AC_CONFIG_COMMANDS([default], [true], [APACHE_GEN_MAKEFILES])
+AC_CONFIG_COMMANDS([default],
+ [$SHELL $srcdir/build/fastgen.sh $srcdir $ac_cv_mkdir_p $BSD_MAKEFILE $APACHE_FAST_OUTPUT_FILES >&AS_MESSAGE_FD],
+ [ac_cv_mkdir_p=$ac_cv_mkdir_p
+BSD_MAKEFILE=$BSD_MAKEFILE
+APACHE_FAST_OUTPUT_FILES="$APACHE_FAST_OUTPUT_FILES"
+])
AC_CONFIG_COMMANDS([modules.c], [
## Build modules.c
rm -f modules.c