summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJeff Trawick <trawick@apache.org>2011-05-09 20:34:42 +0000
committerJeff Trawick <trawick@apache.org>2011-05-09 20:34:42 +0000
commit2f4222c3d77074b71223fbe2700e5cd8b7881b13 (patch)
tree3013a8456c1bf998068726755ab3debdbb2d4fbe /configure.in
parent0998c2e208c9665d22c77a563be7b257aa538d59 (diff)
downloadhttpd-2f4222c3d77074b71223fbe2700e5cd8b7881b13.tar.gz
keep -DAP_HOOK_PROBES_ENABLED (--enable-hook-probes) and
-DAP_DECLARE_EXPORT (MinGW builds) out of the *CPPFLAGS used for third-party module builds introduce INTERNAL_CPPFLAGS for that; apxs bypasses this git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1101211 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bdc5f51f5d..f4fd7d56f3 100644
--- a/configure.in
+++ b/configure.in
@@ -104,6 +104,8 @@ APR_SETIFNULL(CC, `$apr_config --cc`)
APR_SETIFNULL(CPP, `$apr_config --cpp`)
APR_ADDTO(CFLAGS, `$apr_config --cflags`)
APR_ADDTO(CPPFLAGS, `$apr_config --cppflags`)
+dnl internal-only CPPFLAGS (shouldn't affect third-party module builds)
+INTERNAL_CPPFLAGS=""
APR_ADDTO(LDFLAGS, `$apr_config --ldflags`)
SHLIBPATH_VAR=`$apr_config --shlib-path-var`
APR_BINDIR=`$apr_config --bindir`
@@ -305,7 +307,7 @@ case $host in
APR_SETVAR(SINGLE_LISTEN_UNSERIALIZED_ACCEPT, [1])
;;
*mingw32*)
- APR_ADDTO(CPPFLAGS, [-DAP_DECLARE_EXPORT])
+ APR_ADDTO(INTERNAL_CPPFLAGS, [-DAP_DECLARE_EXPORT])
APR_SETIFNULL(ac_cv_func_times, [no])
APR_SETIFNULL(ac_cv_func_getpwnam, [no])
APR_SETIFNULL(ac_cv_func_getgrnam, [no])
@@ -514,7 +516,7 @@ AC_ARG_ENABLE(hook-probes,APACHE_HELP_STRING(--enable-hook-probes,Enable APR hoo
[
AC_DEFINE(AP_HOOK_PROBES_ENABLED, 1,
[Enable the APR hook probes capability, reading from ap_hook_probes.h])
- APR_ADDTO(CPPFLAGS, -DAP_HOOK_PROBES_ENABLED)
+ APR_ADDTO(INTERNAL_CPPFLAGS, -DAP_HOOK_PROBES_ENABLED)
])dnl
AC_ARG_ENABLE(exception-hook,APACHE_HELP_STRING(--enable-exception-hook,Enable fatal exception hook),