summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2020-07-07 13:40:15 +0000
committerJoe Orton <jorton@apache.org>2020-07-07 13:40:15 +0000
commit33d99cf67f4bbdce86be0a0fdbb3d26f18e0f2a7 (patch)
tree6f4ae663614add01978478726de007b673219102 /configure.in
parent023a72b977663bfdb63c12d21bbe2d1c7c530ce7 (diff)
downloadhttpd-33d99cf67f4bbdce86be0a0fdbb3d26f18e0f2a7.tar.gz
Check for and use gettid() directly if available; glibc 2.30 and later
provides a wrapper for the system call: * configure.in: Check for gettid() and define HAVE_SYS_GETTID if gettid() is only usable via syscall(). * server/log.c (log_tid): Use gettid() directly if available. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1879591 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 423d58d4b9..60cbf7b7f8 100644
--- a/configure.in
+++ b/configure.in
@@ -535,22 +535,26 @@ prctl \
timegm \
getpgid \
fopen64 \
-getloadavg
+getloadavg \
+gettid
)
dnl confirm that a void pointer is large enough to store a long integer
APACHE_CHECK_VOID_PTR_LEN
-AC_CACHE_CHECK([for gettid()], ac_cv_gettid,
+if test $ac_cv_func_gettid = no; then
+ # On Linux before glibc 2.30, gettid() is only usable via syscall()
+ AC_CACHE_CHECK([for gettid() via syscall], ap_cv_gettid,
[AC_TRY_RUN(#define _GNU_SOURCE
#include <unistd.h>
#include <sys/syscall.h>
#include <sys/types.h>
int main(int argc, char **argv) {
pid_t t = syscall(SYS_gettid); return t == -1 ? 1 : 0; },
-[ac_cv_gettid=yes], [ac_cv_gettid=no], [ac_cv_gettid=no])])
-if test "$ac_cv_gettid" = "yes"; then
- AC_DEFINE(HAVE_GETTID, 1, [Define if you have gettid()])
+ [ap_cv_gettid=yes], [ap_cv_gettid=no], [ap_cv_gettid=no])])
+ if test "$ap_cv_gettid" = "yes"; then
+ AC_DEFINE(HAVE_SYS_GETTID, 1, [Define if you have gettid() via syscall()])
+ fi
fi
dnl ## Check for the tm_gmtoff field in struct tm to get the timezone diffs