summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGuenter Knauf <fuankg@apache.org>2012-04-21 17:31:30 +0000
committerGuenter Knauf <fuankg@apache.org>2012-04-21 17:31:30 +0000
commit47f57ff5363ff723d35dfc3a3c706ccd4d00ce1f (patch)
tree1b22690c038b340cb5b9156693abef531735ca69 /configure.in
parent0767959631652653ca0c7cdb7083c0b3f0511f91 (diff)
downloadhttpd-47f57ff5363ff723d35dfc3a3c706ccd4d00ce1f.tar.gz
Final step to make cross compilation working.
In case of cross compilation set CC_FOR_BUILD to cc unless we got already CC_FOR_BUILD from environment. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1328714 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 26ba03ba44..10d645cd7e 100644
--- a/configure.in
+++ b/configure.in
@@ -193,6 +193,14 @@ AC_PROG_CPP
dnl Try to get c99 support for variadic macros
ifdef([AC_PROG_CC_C99], [AC_PROG_CC_C99])
+dnl In case of cross compilation we set CC_FOR_BUILD to cc unless
+dnl we got already CC_FOR_BUILD from environment.
+if test "x${build_alias}" != "x${host_alias}"; then
+ if test "x${CC_FOR_BUILD}" = "x"; then
+ CC_FOR_BUILD=cc
+ fi
+fi
+
if test "x${cache_file}" = "x/dev/null"; then
# Likewise, ensure that CC and CPP are passed through to the pcre
# configure script iff caching is disabled (the autoconf 2.5x default).