summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJim Jagielski <jim@apache.org>2017-10-03 12:53:04 +0000
committerJim Jagielski <jim@apache.org>2017-10-03 12:53:04 +0000
commit4fc8d9cdc9a6a9c9a6feb48d446972367278a22c (patch)
tree50c7e8ec2daacc301e3c4150da9c1890c9e2e1aa /configure.in
parenta01e89c88536bc78eb8b5ef183c1767191c6c349 (diff)
downloadhttpd-4fc8d9cdc9a6a9c9a6feb48d446972367278a22c.tar.gz
Also affects official clang 5 (maybe older ones too...)
git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1810998 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 43a5053fe8..6ce487010d 100644
--- a/configure.in
+++ b/configure.in
@@ -631,7 +631,7 @@ AC_ARG_ENABLE(maintainer-mode,APACHE_HELP_STRING(--enable-maintainer-mode,Turn o
if test "$GCC" = "yes"; then
APR_ADDTO(CFLAGS,[-Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Wpointer-arith])
case `($CC --version) 2>/dev/null` in
- *clang-900*)
+ *clang-900* | *"clang version 5.0.0"*)
APACHE_ADD_GCC_CFLAG([-Wno-error=strict-prototypes])
;;
esac
@@ -662,7 +662,7 @@ AC_ARG_ENABLE(debugger-mode,APACHE_HELP_STRING(--enable-debugger-mode,Turn on de
if test "$GCC" = "yes"; then
APR_ADDTO(CFLAGS,[-Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Wpointer-arith -O0])
case `($CC --version) 2>/dev/null` in
- *clang-900*)
+ *clang-900* | *"clang version 5.0.0"*)
APACHE_ADD_GCC_CFLAG([-Wno-error=strict-prototypes])
;;
esac