summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRainer Jung <rjung@apache.org>2017-10-16 09:15:27 +0000
committerRainer Jung <rjung@apache.org>2017-10-16 09:15:27 +0000
commit6958a604434bd89eb20a2cda4a62bcfe4b84eb62 (patch)
tree589841ae23e4bf46cbb24dc7433be2c19a49f0c7 /configure.in
parent14716ce0e07aa73bca54b5037bbcb6cf92b9cedb (diff)
downloadhttpd-6958a604434bd89eb20a2cda4a62bcfe4b84eb62.tar.gz
GCC/Clang strict-prototypes handling in configure:
revert r1810998 and r1810448 before applying a more general solution. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1812261 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 6ce487010d..ef7bd02482 100644
--- a/configure.in
+++ b/configure.in
@@ -630,11 +630,6 @@ AC_ARG_ENABLE(maintainer-mode,APACHE_HELP_STRING(--enable-maintainer-mode,Turn o
APR_ADDTO(CPPFLAGS, -DAP_DEBUG)
if test "$GCC" = "yes"; then
APR_ADDTO(CFLAGS,[-Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Wpointer-arith])
- case `($CC --version) 2>/dev/null` in
- *clang-900* | *"clang version 5.0.0"*)
- APACHE_ADD_GCC_CFLAG([-Wno-error=strict-prototypes])
- ;;
- esac
APACHE_ADD_GCC_CFLAG([-std=c89])
APACHE_ADD_GCC_CFLAG([-Werror])
APACHE_ADD_GCC_CFLAG([-Wdeclaration-after-statement])
@@ -661,11 +656,6 @@ AC_ARG_ENABLE(debugger-mode,APACHE_HELP_STRING(--enable-debugger-mode,Turn on de
APR_ADDTO(CPPFLAGS, -DAP_DEBUG)
if test "$GCC" = "yes"; then
APR_ADDTO(CFLAGS,[-Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Wpointer-arith -O0])
- case `($CC --version) 2>/dev/null` in
- *clang-900* | *"clang version 5.0.0"*)
- APACHE_ADD_GCC_CFLAG([-Wno-error=strict-prototypes])
- ;;
- esac
APACHE_ADD_GCC_CFLAG([-Wdeclaration-after-statement])
APACHE_ADD_GCC_CFLAG([-Werror=declaration-after-statement])
APACHE_ADD_GCC_CFLAG([-Wformat])