summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBen Reser <breser@apache.org>2014-04-07 21:26:23 +0000
committerBen Reser <breser@apache.org>2014-04-07 21:26:23 +0000
commit80d149de6b075d5875bc395a6743e5df53fbcd1f (patch)
tree8738de4e7738e73d65ec5a6cd922ab652ae0b3af /configure.in
parent08346fc97286230dfaf5e36d27065b52d2695d2c (diff)
downloadhttpd-80d149de6b075d5875bc395a6743e5df53fbcd1f.tar.gz
Fix PCRE_DUPNAMES check to find the header file for PCRE when PCRE isn't in
the default includes path. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1585590 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 549416b72f..e0d1094e3d 100644
--- a/configure.in
+++ b/configure.in
@@ -272,6 +272,8 @@ APR_ADDTO(INCLUDES, $APU_INCLUDES)
dnl Add in path to PCRE includes
APR_ADDTO(INCLUDES, $PCRE_INCLUDES)
+save_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS $PCRE_INCLUDES"
AC_EGREP_CPP(yes,
[
#include <pcre.h>
@@ -282,6 +284,7 @@ yes
if test "$pcre_have_dupnames" != "yes"; then
AC_MSG_ERROR([pcre version does not support PCRE_DUPNAMES])
fi
+CPPFLAGS="$save_CPPFLAGS"
AC_MSG_NOTICE([])
AC_MSG_NOTICE([Applying OS-specific hints for httpd...])