summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRainer Jung <rjung@apache.org>2012-02-14 07:11:36 +0000
committerRainer Jung <rjung@apache.org>2012-02-14 07:11:36 +0000
commit969762d30ee83147d467d46d826f7cae432b458b (patch)
tree36b279050ece7fd8264365bc5d8d6e44ad32a31f /configure.in
parent8b2ec33ac5d314be345814db08e194ffeda6beb0 (diff)
downloadhttpd-969762d30ee83147d467d46d826f7cae432b458b.tar.gz
Fix out of tree build with srclib apr.
Fix error message for included apr flag. Forward port of r1241897 and r1243670 from 2.4.x plus one shell syntax fix. Will backport the fix to 2.4.x. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1243797 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 488a3a5186..112f551816 100644
--- a/configure.in
+++ b/configure.in
@@ -88,7 +88,8 @@ APACHE_HELP_STRING(--with-included-apr,Use bundled copies of APR/APR-Util))
if test "x$with_included_apr" = "xyes"; then
apr_found=reconfig
if test ! -d srclib/apr; then
- AC_MSG_ERROR([Bundled APR requested but not found at srclib/apr. Download and unpack the corresponding httpd-${HTTPD_VERSION}-deps package over this one.])
+ if test ! -d srclib/apr && test ! -d $srcdir/srclib/apr; then
+ AC_MSG_ERROR([Bundled APR requested but not found at ./srclib/. Download and unpack the corresponding apr and apr-util packages to ./srclib/.])
fi
else
APR_FIND_APR("$srcdir/srclib/apr", "./srclib/apr", 1, 1 2)
@@ -136,8 +137,8 @@ if test "x${apr_major_version}" = "x2"; then
apu_found=obsolete
elif test "x$with_included_apr" = "xyes"; then
apu_found=reconfig
- if test ! -d srclib/apr-util; then
- AC_MSG_ERROR([Bundled APR-Util requested but not found at srclib/apr-util. Download and unpack the corresponding httpd-${HTTPD_VERSION}-deps package over this one.])
+ if test ! -d srclib/apr-util && test ! -d $srcdir/srclib/apr-util; then
+ AC_MSG_ERROR([Bundled APR-Util requested but not found at ./srclib/. Download and unpack the corresponding apr and apr-util packages to ./srclib/.])
fi
else
dnl If httpd is buildconf'ed against an apr 2.x tree, then 1.x