summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJim Jagielski <jim@apache.org>2014-03-19 15:23:35 +0000
committerJim Jagielski <jim@apache.org>2014-03-19 15:23:35 +0000
commita0529d925ccffde34bc7e0c4b73c173e0eebec70 (patch)
tree5be9ea6b0a061a0c59e42be2ec6710dda92214bb /configure.in
parenta9467ff9a13d5c50a1bb3622b6884b9549bcf2ac (diff)
downloadhttpd-a0529d925ccffde34bc7e0c4b73c173e0eebec70.tar.gz
Check if PCRE_DUPNAMES exists at configure time
git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1579259 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 937cd441f4..549416b72f 100644
--- a/configure.in
+++ b/configure.in
@@ -272,6 +272,17 @@ APR_ADDTO(INCLUDES, $APU_INCLUDES)
dnl Add in path to PCRE includes
APR_ADDTO(INCLUDES, $PCRE_INCLUDES)
+AC_EGREP_CPP(yes,
+[
+#include <pcre.h>
+#ifdef PCRE_DUPNAMES
+yes
+#endif
+],pcre_have_dupnames=yes,pcre_have_dupnames=no)
+if test "$pcre_have_dupnames" != "yes"; then
+ AC_MSG_ERROR([pcre version does not support PCRE_DUPNAMES])
+fi
+
AC_MSG_NOTICE([])
AC_MSG_NOTICE([Applying OS-specific hints for httpd...])
AC_MSG_NOTICE([])