summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStefan Fritsch <sf@apache.org>2012-05-27 21:40:00 +0000
committerStefan Fritsch <sf@apache.org>2012-05-27 21:40:00 +0000
commita1b0be3dcba63937b705887299959ab83975eb75 (patch)
tree6d63beb9720a16f88c689d1f0c1a3081d7d68983 /configure.in
parentf25013b32d347d855378c92776625a320935084a (diff)
downloadhttpd-a1b0be3dcba63937b705887299959ab83975eb75.tar.gz
Make ap_regcomp() return AP_REG_ESPACE if out of memory. Make ap_pregcomp()
abort if out of memory. This raises the minimum PCRE requirement to version 6.0, released in 2005. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1343109 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 19ebd887d6..ead96cd09a 100644
--- a/configure.in
+++ b/configure.in
@@ -225,6 +225,11 @@ if test "$PCRE_CONFIG" != "false"; then
if $PCRE_CONFIG --version >/dev/null 2>&1; then :; else
AC_MSG_ERROR([Did not find pcre-config script at $PCRE_CONFIG])
fi
+ case `$PCRE_CONFIG --version` in
+ [[1-5].*])
+ AC_MSG_ERROR([Need at least pcre version 6.0])
+ ;;
+ esac
AC_MSG_NOTICE([Using external PCRE library from $PCRE_CONFIG])
APR_ADDTO(PCRE_INCLUDES, [`$PCRE_CONFIG --cflags`])
APR_ADDTO(PCRE_LIBS, [`$PCRE_CONFIG --libs`])