summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilliam A. Rowe Jr <wrowe@apache.org>2016-12-12 06:45:11 +0000
committerWilliam A. Rowe Jr <wrowe@apache.org>2016-12-12 06:45:11 +0000
commitb9df8eff5cf5f430d0f7f72c05925f2b07b45c45 (patch)
treec391e6469bb8df39f1e06ca21882abe39f2278d6 /configure.in
parent12cfcf08fffc6e4ec597e0396016d09afdb89fa8 (diff)
downloadhttpd-b9df8eff5cf5f430d0f7f72c05925f2b07b45c45.tar.gz
Fixes to --with-pcre. Refuse to consider --without-pcre, that is
nonsequitor. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1773741 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5e70d7aee0..4de5d4b731 100644
--- a/configure.in
+++ b/configure.in
@@ -222,10 +222,16 @@ fi
AC_ARG_WITH(pcre,
APACHE_HELP_STRING(--with-pcre=PATH,Use external PCRE library))
+echo PCRE PATH was $with_pcre
+
+if test "$with_pcre" = "" || test "$with_pcre" = "yes"; then
+ with_pcre = "$PATH"
+else
+ with_pcre = "$with_pcre/bin:$with_pcre"
+fi
AC_CHECK_TARGET_TOOLS(PCRE_CONFIG, [pcre2-config pcre-config],
- [`which $with_pcre 2>/dev/null`],
- [$with_pcre/bin:$with_pcre])
+ [`which $with_pcre 2>/dev/null`], $with_pcre)
if test "x$PCRE_CONFIG" != "x"; then
if $PCRE_CONFIG --version >/dev/null 2>&1; then :; else