summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRainer Jung <rjung@apache.org>2017-11-08 23:58:16 +0000
committerRainer Jung <rjung@apache.org>2017-11-08 23:58:16 +0000
commitc4965acb8b23ccb8dca5dccbfb02ee3324222931 (patch)
treef61669d708b9b1f5fb70eb3549d5e182cc34c9eb /configure.in
parente8a57f3e7d96328d33c23c6a967b9fdb01f5c208 (diff)
downloadhttpd-c4965acb8b23ccb8dca5dccbfb02ee3324222931.tar.gz
Fix pcre feature detection in configure when
using pcre2. Follow up to r1773454. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1814662 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9cda3d86c7..4315aa1cc4 100644
--- a/configure.in
+++ b/configure.in
@@ -284,10 +284,14 @@ save_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $PCRE_INCLUDES"
AC_EGREP_CPP(yes,
[
+#ifdef HAVE_PCRE2
+yes
+#else
#include <pcre.h>
#ifdef PCRE_DUPNAMES
yes
#endif
+#endif
],pcre_have_dupnames=yes,pcre_have_dupnames=no)
if test "$pcre_have_dupnames" != "yes"; then
AC_MSG_ERROR([pcre version does not support PCRE_DUPNAMES])