summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJacob Champion <jchampion@apache.org>2017-01-04 23:14:27 +0000
committerJacob Champion <jchampion@apache.org>2017-01-04 23:14:27 +0000
commitc856f32b9616aac5f0803305638784e56c3f3791 (patch)
tree31155f1e8277fcb508183928a392d168b0d0271d /configure.in
parent56e7d50f691490266f37e17f6b77fb388dff0209 (diff)
downloadhttpd-c856f32b9616aac5f0803305638784e56c3f3791.tar.gz
Add a --with-test-suite option for "in-tree" testing
Step one. It's not actually "in-tree" yet, since it requires running `make install` first, but at least it gives us a `make check`. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/branches/trunk-test-integration@1777384 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 19ce9e7374..db26629e99 100644
--- a/configure.in
+++ b/configure.in
@@ -886,6 +886,21 @@ AC_ARG_ENABLE(bsd-makefiles,APACHE_HELP_STRING(--enable-bsd-makefiles,use BSD Ma
FORCE_BSD_MAKEFILE="auto"
])
+AC_ARG_WITH([test-suite],
+ APACHE_HELP_STRING([--with-test-suite=PATH], [enable in-tree 'make check' with the given Apache::Test suite location]),
+ [
+ if test "x$withval" = "xyes"; then
+ AC_MSG_ERROR([option --with-test-suite requires a directory]);
+ else
+ test -f "$withval/Makefile.PL" || AC_MSG_WARN([--with-test-suite directory $withval does not appear to contain the expected Makefile.PL])
+ TEST_SUITE_LOCATION="$withval"
+ fi
+ ],
+ [ TEST_SUITE_LOCATION="no" ]
+)
+
+APACHE_SUBST(TEST_SUITE_LOCATION)
+
APACHE_FAST_OUTPUT(Makefile modules/Makefile srclib/Makefile)
APACHE_FAST_OUTPUT(os/Makefile server/Makefile)
APACHE_FAST_OUTPUT(support/Makefile)