summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWilliam A. Rowe Jr <wrowe@apache.org>2016-12-12 20:51:17 +0000
committerWilliam A. Rowe Jr <wrowe@apache.org>2016-12-12 20:51:17 +0000
commitc960136851d6141ec08e782cb8fba418e91267b5 (patch)
treeb6e43d11169e92f5751420be8c06dcb6f613b94f /configure.in
parent366a562546a3ebb70a2be088665e93eb319cec8e (diff)
downloadhttpd-c960136851d6141ec08e782cb8fba418e91267b5.tar.gz
Need to preserve --with-pcre value if not a path ref
git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1773870 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 659f6e61dc..19ce9e7374 100644
--- a/configure.in
+++ b/configure.in
@@ -224,9 +224,10 @@ AC_ARG_WITH(pcre,
APACHE_HELP_STRING(--with-pcre=PATH,Use external PCRE library))
if test "x$with_pcre" = "x" || test "$with_pcre" = "yes"; then
with_pcre="$PATH"
-else
+else if which $with_pcre 2>/dev/null; then :; else
with_pcre="$with_pcre/bin:$with_pcre"
fi
+fi
AC_CHECK_TARGET_TOOLS(PCRE_CONFIG, [pcre2-config pcre-config],
[`which $with_pcre 2>/dev/null`], $with_pcre)