summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2021-02-25 09:11:57 +0000
committerJoe Orton <jorton@apache.org>2021-02-25 09:11:57 +0000
commitce017390110ce49ca9eccba8b2eabfc2870b7932 (patch)
treef0c689850af061a4ffad8a945a903ac225b551c9 /configure.in
parent89859aab378cba086ecb21d5057b285cdd17ae4b (diff)
downloadhttpd-ce017390110ce49ca9eccba8b2eabfc2870b7932.tar.gz
Enable mod_cgid stderr handling via Unix socket fd transfer by
default, rather than as an opt-in configure flag. (This has been tested in Fedora for >12 months without seeing any new problems) * configure.in: Check for CMSG_DATA here, and define HAVE_FDPASSING and $ap_has_fdpassing if fd passing is supported. * modules/generator/config5.m4, modules/generator/mod_cgid.c: Drop configure flag for mod_cgid fdpassing support, instead enable where possible by default. * modules/proxy/config.m4: Rely on configure test for CMSG_DATA. * .travis.yml: Switch test for cgid fdpassing for testing w/o CMSG_DATA. Github: closes #172 PR: 54221 git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1886912 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0e81ab5510..9a56af7c76 100644
--- a/configure.in
+++ b/configure.in
@@ -567,6 +567,16 @@ if test "$ac_cv_struct_tm_gmtoff" = "yes"; then
AC_DEFINE(HAVE_GMTOFF, 1, [Define if struct tm has a tm_gmtoff field])
fi
+AC_CHECK_DECL(CMSG_DATA,,, [#include <sys/types.h>
+#include <sys/socket.h>])
+if test $ac_cv_have_decl_CMSG_DATA = "yes"; then
+ AC_DEFINE([HAVE_FDPASSING], 1, [Define if file descriptor passing is supported])
+ ap_has_fdpassing=1
+else
+ ap_has_fdpassing=0
+ AC_MSG_WARN([This system does not support file descriptor passing.])
+fi
+
APACHE_CHECK_SYSTEMD
dnl ## Set up any appropriate OS-specific environment variables for apachectl